1

I'm performing an AIX migration from 7.1 to 7.2 using the DVD Iso on a VIOS Virtual Library.

At the point the migration starts, it fails with the following message:

0516-1775 varyonvg: Physical volumes hdisk0 and hdisk4 have identical PVIDs (00cdc0334d8c16a1).

I know this is happening because the LUNS are provided via Netapp Storage and the SMS Menu doesn't support the Multipathing Software, so instead of a Disk with 4 paths, SMS interprets it as 4 disks with PVID conflict.

If I ask the Netapp team to kill all paths except one, it works. But I don't want to do it for all LPARs in my environment.

How do I avoid this without involving Netapp team?

Regards

Dumb admin
  • 127
  • 12
  • Hi. I'm no expert in AIX, but multipathing should be supported on AIX for FC with NetApp using native IBM AIX MPIO. AIX 7.2 supported with ONTAP from 8.2 to 9.4 – BBK Jun 14 '18 at 14:09
  • What ONTAP version, Host File System, Host Clustering, Host Volume Manager & Host HBA do you have? – BBK Jun 14 '18 at 14:13
  • Hi @BBK The problem is not on a running AIX, but during the migration which happens with the AIX down. The SMS calls then the migration process which invokes a very small limited 'AIX' to handle the LVM. During this phase, the Root Volume Group is imported, but as the duplicated PVID happens, the importvg programs stops, so does the migration. – Dumb admin Jun 14 '18 at 14:34
  • Hi @Dumb admin, sorry I'm storage guy, not AIX guy do not know what SMS is... – BBK Jun 14 '18 at 14:35
  • If you can't remove paths from AIX by your own, I suppose the only one way left is to ask your NetApp storage team. – BBK Jun 14 '18 at 14:46

2 Answers2

2

For FC & FCoE with AIX 7.2 (all revisions & SPs) supported with NetApp ONTAP from 8.2 (7-Mode & Cluster Mode) to ONTAP 9.4.

To be precise here are supported configurations:

  • Host Volume Manager: IBM AIX LVM or Oracle ASM
  • Host File System: GPFS, IBM AIX, RawIO, JFS, Oracle ASM
  • Host Clustering: IBM PowerHA (HACMP), Oracle RAC
  • Host HBA: IBM HBA FC5270, IBM HBA FC5708, IBM HBA FCEN0H, IBM HBA FCEN0J, IBM HBA FCEN0K, IBM HBA FCEN0L

It is recommended in your case to install NetApp AIX Host Utilities 6.0. Native AIX multipating (IBM AIX MPIO) supported with those versions of ONTAP. I would recommend you to configure MPIO properly instead of removing paths.

Here is the NetApp KB article which will help you to check MPIO configuration.

But if it is only temporary solution to remove paths, just lets say for upgrade purposes, and if you can't remove them from AIX, then you should ask your storage admins, they can use Selective LUN Map or Portset to remove all the paths and leave to you only one path.

BBK
  • 505
  • 1
  • 5
  • 18
1

It turns out there is no official support to NetApp MPIO during a DVD BOS Install. I've opened a support case at IBM and they confirmed it. I was able though, to work around it using 'non-official' ways.

First, start the installation processing booting from the DVD.

At the "Welcome to Base Operating System" menu, choose "3 Start Maintenance Mode for System Recovery" :

3 Start Maintenance Mode for System Recovery

Then in the 'Maintenance' Menu Select "3 Access Advanced Maintenance Functions":

3 Access Advanced Maintenance Functions

There, remove all disks (paths), with the exception of one, which will be used to be migrated/installed. You can use the following script to remove the disks:

disk=hdisk0
for pv in $(lspv | grep -v "$disk " | cut -d ' ' -f1)
do
   rmdev -dl $pv
done
exit # Going Back the Migration Menu

This solves the first PVID problem, so after you are back to the migration menu, go back to the installation options and start the migration. Finally, the Migration will continue and all packages will be installed. But there will be another issue at the very end. At the point when the boot section will be installed in the disk, the duplicated disks will be back, and this step will fail. But I was able to install it myself with the following steps:

disk=hdisk0 #The Migrated/installed PV
for pv in $(lspv | grep -v "$disk " | cut -d ' ' -f1)
do
   rmdev -dl $pv
done

importvg -Oy rootvg $disk

mount /usr
/etc/methods/cfg64
ln -fs /usr/lib/boot/unix_64 /unix
ln -fs /usr/lib/boot/unix_64 /usr/lib/boot/unix
mkboot -cd/dev/$disk
cp -rp /usr/lpp/bos/inst_root/etc/rc.teboot /etc/rc.teboot
cp -rp /usr/lpp/bos/inst_root/sbin/rc.boot /sbin/rc.boot
bosboot -ad /dev/$disk

Hope this helps someone in trouble like I was

Regards

Dumb admin
  • 127
  • 12