Giving a switch an IP Address so I can telnet into it

0

Right, so I've just reloaded my switch resetting the to complete default configuration. It's a Cisco Catalyst 3560. What I am trying to achieve is this: Giving the switch an IP Address, then telnet to it from my computer.

What I have done so far:

Disconnected from my wifi. Entered ipconfig, it said this - Autoconfiguration IPv4 Address. . : 169.254.88.16

I assumed that is my laptops IP address.

I assigned my laptops IP address as the default gateway on the route using the command ip default-gateway 169.254.88.16

I then went into Vlan1 and typed ip address 192.168.1.100 255.255.255.0 giving it an IP address. and entered no shutdown.

I then went into FastEthernet 0/1 and entered switchport access vlan 1, but for some reason it never showed up on the config, it just wasn't accepting the command and then I typed no shutdown.

I then went to my computer and pinged 192.168.1.100 and got request timed out. What am I doing wrong?

Here is my config Building configuration...

*Mar  1 00:18:07.465: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 2078 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface FastEthernet0/27
!
interface FastEthernet0/28
!
interface FastEthernet0/29
!
interface FastEthernet0/30
!
interface FastEthernet0/31
!
interface FastEthernet0/32
!
interface FastEthernet0/33
!
interface FastEthernet0/34
!
interface FastEthernet0/35
!
interface FastEthernet0/36
!
interface FastEthernet0/37
!
interface FastEthernet0/38
!
interface FastEthernet0/39
!
interface FastEthernet0/40
!
interface FastEthernet0/41
!
interface FastEthernet0/42
!
interface FastEthernet0/43
!
interface FastEthernet0/44
!
interface FastEthernet0/45
!
interface FastEthernet0/46
!
interface FastEthernet0/47
!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface Vlan1
 ip address 192.168.1.100 255.255.255.0
!
ip default-gateway 169.254.88.16
ip classless
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end

Coder77

Posted 2014-06-29T11:45:49.500

Reputation: 103

An 169.254... address is a dummy address which means, There was no DHCP server that could hand out an IP Address, so you're not connected to any network. – LPChip – 2014-06-29T12:29:12.923

So what do I assign as the default gateway on the switch? – Coder77 – 2014-06-29T12:29:41.790

The default gateway address is the IP Address of the device that supplies internet access. If you have a router, its ip address would be the default gateway. If you don't, then the modem would be the default gateway. If your switch can act as a router, then the switch will be the default gateway. But note, in order to have more than one pc's connect to the internet at the same time, you have to have a router in your setup somewhere. A normal switch is not a router. Some modems are Modem/Router combo's. – LPChip – 2014-06-29T12:31:27.020

As there is no router in this network just the switch and the computer do I make the default gateway the of the switch it's own IP address? – Coder77 – 2014-06-29T12:35:33.213

if you don't require access to other networks than the local network, you don't need to add a gateway. A gateway is ANY device that knows how to connect you to a different network (e.g. "the internet", but also other subnets within your network). Without a gateway, your switch only knows how to send packets to the subnet it is configured for. – Jakke – 2014-06-29T12:57:13.250

Also, the 169 ip address is Microsoft's implementation to provide local ip access for computers that are on a local area network without a DHCP server. If you configure a couple of computers to use DHCP and there's no DHCP server on the network, they will still be able to talk to each other using the 169.x.x.x subnet. It does not mean that you have no network connectivity if you see an address like that, it just means your network card doesn't get an IP from a DHCP server. – Jakke – 2014-06-29T13:00:00.457

Answers

0

It is important to note that your host and switch will need to be on the same subnet in order to establish network connectivity to and from each other. To do this you will need to assign a static IP address to both your host and switch.


Configuring Static IP Adresses in Windows:

  1. In Windows 8 press Windows Key + X then W to open your network connections from the quick-access menu. Otherwise perform a search for Network And Sharing Center through Windows Explorer.
  2. Right-click the interface that you would like to configure an IP address on.
  3. In the context menu of the interface click Properties.
  4. Scroll down and click to select IPv4.
  5. Click the Properties button.
  6. Click to select the Use the following IP address radio button.
  7. Use an IP address between 0.0.0.0 - 255.255.255.255 (excluding the loopback address, which is always 127.0.0.1).
    • I suggest using 192.168.1.x (where x is a number between 0 and 255) as an address because it is common.
  8. For the subnet mask I would suggest using 255.255.255.0. This will allow you to allocate 254 addresses to hosts on your network. You cannot use 0 or 255 as your selected IP address. If you'd like to learn more about subnetting you can find out about it by clicking here.
  9. The default gateway will be the IP address that you assigned to your switch. The switch should have an IP address of 192.168.1.x (where x has the same range as the bullet in step seven but is a different number in that range to avoid an IP address conflict) and a subnet mask of 255.255.255.0.
  10. You can leave the DNS configuration alone since it doesn't sound like you will be performing DNS lookups yet.
  11. Click OK.

Microsoft has published an article on how to do this, which you can find by clicking here

Cisco's Getting Started guide for your switch will help you out as well; it can be found by clicking here.

And here is Cisco's Software Configuration Guide to get telnet setup on your switch.

cody.codes

Posted 2014-06-29T11:45:49.500

Reputation: 1 172

I understand you must be on the same subnet, however, which IP address and which subnet? – Coder77 – 2014-06-29T12:28:42.023