OpenWrt with multiple radios

3

I have three Compex boards running OpenWrt. I have connected two Qualcomm radios to each of the boards. I am trying to configure one of these boards as an access point (AP mode), and other two in station mode (STA mode). I bring up two Wi-Fi interfaces — wlan0 and wlan1 — on the AP (configured to use two different SSID's) as:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '165'
        option hwmode '11n'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'W0'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '153'
        option hwmode '11n'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'W1'
        option encryption 'none'

In one of my stations, I enable radio0 and in the other one I enable radio1.

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11n'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'sta'
        option ssid 'OpenWrt'
        option encryption 'none'

AND

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11n'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'sta'
        option ssid 'OpenWrt'
        option encryption 'none'

Then I assign ip addresses:
On the AP:

ifconfig wlan0 1.1.2.52
ifconfig wlan1 1.1.3.52

On one station:

ifconfig wlan0 1.1.2.61

On the other station:

ifconfig wlan1 1.1.3.61

Then I add all the required ARP entries of the AP to the stations and the stations to the AP using commands similar to:

arp -i wlan0 -s 1.1.2.61 hw_address_of_wlan0

But I am only able to get one of them to send ping messages at one time (either I am able to send traffic over wlan0 or wlan1). Can someone tell me how can I get both wlan0 and wlan1 to send traffic simultaneously?

LinuxUser

Posted 2018-06-29T18:13:41.210

Reputation: 51

Could you edit the question with the output of ifconfig (or ip addr) on the AP to verify the netmasks etc. are correct? If they are correct, also check the routes (route or ip route). (BTW, better use the 10...* private IP range instead of 1.1.2.* and 1.1.3.*). – dirkt – 2018-06-30T17:42:47.860

No answers