Openwrt doesn't work dhcp

2

1

I have my ISP Modem connect to my TP-Link (AC1750 v2). And have bridge connection between LAN and WAN (ISP Modem). This is working fine, but I have to manually setup the IP and the gateway, for example: my PC IP: 192.168..1.16. Subnet Mask: 255.255.255.0 Default gateway: 192.168.1.3

But can't connect (wired o wireless) without setting the IP manually.

etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd50:789f:3c13::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ip6assign '60'
        option ipaddr '192.168.1.3'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'


config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
      option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6'

etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:01/0000:01:00.0'
        option htmode 'VHT80'
        option txpower '17'
        option channel 'auto'
        option country 'AR'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Om Shanti'
        option encryption 'psk2'
        option key 'limonadafresca'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca955x_wmac'
        option htmode 'HT20'
        option txpower '24'
        option country 'AR'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Om Shanti'
        option encryption 'psk2'
        option key 'limonadafresca'

Giorgio

Posted 2017-06-04T00:09:48.053

Reputation: 31

No answers