0

I have following network:
http://imgur.com/M4BCWXv

So want to connect 2 subnets:
VLAN 10 - programmer - network 155.55.3.0 / 26 - left side
VLAN 10 - programmer - network 155.55.0.0 / 23 - right side
Hosts have address from DHCPs on each router
Routing method is EIGRP
I use NAT for VLAN translation

Problem is that there is weird connection problem:

From Router0 I can ping to PC1

From PC0 i can ping max. to Router1 (10.0.0.2)

From Router1 I can ping max to Router0 (10.0.0.1)

From PC1 I can ping max to Router0 (10.0.0.1)

Switch x2 - configuration:

enable
configure terminal
vlan 10
name programmer
end
interface range fastEthernet 0/1-17
switchport access vlan 10
exit
interface range gigabitEthernet 0/1-2
switchport mode trunk
switchport trunk allowed vlan add 10
end

Router0 configuration:

enable
configure terminal

interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 155.55.3.1 255.255.255.192
ip nat inside
no sh
exit

interface FastEthernet1/0
ip address 10.0.0.1 255.0.0.0
ip nat outside
no sh
exit

router eigrp 10
network 155.55.3.0 255.255.255.192
network 155.55.0.0 255.255.254.0
network 10.0.0.0 255.0.0.0
no auto-summary

access-list 101 permit ip any any
ip nat inside source list 101 interface FastEthernet1/0 overload

ip dhcp pool programmer
network 155.55.3.0 255.255.255.192
default-router 155.55.3.1
ip dhcp excluded-address 155.55.3.1

Router 1 configuration:

enable
configure terminal

interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 155.55.0.1 255.255.254.0
ip nat inside
no sh
exit

interface FastEthernet1/0
ip address 10.0.0.2 255.0.0.0
ip nat outside
no sh
exit

router eigrp 10
network 155.55.3.0 255.255.255.192
network 155.55.0.0 255.255.254.0
network 10.0.0.0 255.0.0.0
no auto-summary

access-list 101 permit ip any any
ip nat inside source list 101 interface FastEthernet1/0 overload

ip dhcp pool programmer
network 155.55.0.0 255.255.254.0
default-router 155.55.0.1
ip dhcp excluded-address 155.55.0.1

Did I make some configuration mistakes? Is that even possible to do what I want?

Kabool
  • 1
  • 1

1 Answers1

0

Ok, I solve problem. That was really unecessary to use here NAT transaltion. I delete that and works perfectly :)

Kabool
  • 1
  • 1