1

TL;DR: routing daemon not updating tables. Help!

Consider two different Linux vm's configured for routing, R1 and R2, which are directly connected on 10.0.0.0/24. Each has other networks on their other interfaces. They probably want to advertise the networks they are connected to, to each other.

Both routers can successfully ping each other. When static routes are configured, packets are successfully forwarded.

But maintaining static routing tables is a pain, so I installed and configured Quagga on both (configurations below). Despite verifying everything I could on these configs and routers, their routing tables will not update each other.

Update: R1 does list R2 as a neighbor in "show ip ospf neighbors". R2, however, does not list R1 as a neighbor.

Since ping and static routes do work, I am thinking that it has to be the Qugga configurations. Can someone spot whatever it is I've done wrong and point it out to me?

R1's zebra.conf:

hostname R1
password *redacted*
enable password *redacted*
log file /var/log/quagga/zebra.log
!
interface eth0
 ip address 10.0.0.1/24
 ipv6 nd suppress-ra
!
interface eth1
 ip address 172.31.99.1/24
 ipv6 nd suppress-ra
!
interface eth2
 ip address 10.22.6.0/24
 ipv6 nd suppress-ra
!
interface eth3
 ip address 10.1.0.1/16
 ipv6 nd suppress-ra
!
interface lo
!
ip forwarding
!
!
line vty

R1's ospfd.conf:

hostname backbone-ospf
password *redacted*
enable password *redacted*
log stdout
!
interface eth0
 ip ospf priority 255
!
interface eth1
!
interface eth2
!
interface eth3
!
interface lo
!
router ospf
 network 10.0.0.0/24 area 0.0.0.0
 network 10.1.0.0/16 area 0.0.0.0
 network 10.2.6.0/24 area 0.0.0.0
 network 192.168.99.0/24 area 0.0.0.0
 redistribute connected
!
line vty
!

R2'2 zebra.conf:

hostname R2
password *redacted*
enable password *redacted*
log file /var/log/quagga/zebra.log
!
interface eth0
 ip address 10.0.0.12/24
 ipv6 nd suppress-ra
!
interface eth1
 ip address 172.16.0.1/25
 ipv6 nd suppress-ra
!
interface lo
!
ip forwarding
!
!
line vty

R2's ospfd.conf:

hostname isp-ospf
password *redacted*
enable password *redacted*
log stdout
 !
interface eth0
 ip ospf priority 0
!
interface eth1
!
interface eth2
!
interface eth3
!
interface lo
!
router ospf
 network 10.0.0.0/24 area 0.0.0.0
 network 172.16.0.0/25 area 0.0.0.0
 redistibute connected
!
line vty
user349251
  • 53
  • 1
  • 8

0 Answers0