0

I'm trying to create a configuration and it's doing most of what I want it to do, but the DHCP pool isn't assigning addresses. Here's the config so far:

enable 
config t
hostname xxxxxx
enable password xxxxxxx
enable password secret xxxxxx
service password encryption
username xxxxx privilege 15 password 0 xxxxxxx
banner motd #This router is private property and may not be accessed without permission of the owner#
ip domain-lookup
ip domain-name cisco.com 
ip name-server 192.168.1.2
crypto key generate rsa 
512
line con 0 
password xxxxxxxxx
login local 
exec-timeout 0 0 
logging synchronous 
line vty 0 15
password xxxxxxxxxxx
login local 
exec-timeout 0 0 
logging synchronous
transport input all
exit
int f0/0
ip address 216.xxx.xxx.xxx
description connection to ISP 
no shut 
exit 
ip dhcp excluded-address 192.168.1.1
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 216.xxx.xxx.xxx
dns-server 8.8.8.8
exit 
int range fa0/1/0-3
switchport mode access
switchport access vlan 1
spanning-tree portfast 
exit 
ip route 0.0.0.0 0.0.0.0 216.xxx.xxx.xxx
int vlan1
ip address 192.168.1.1 255.255.255.0
no shut 
exit 
exit
wr

I've been staring at this for a while, so I'm probably just missing something obvious, but any help would be greatly appreciated.

--edit-- Starting to see some of the issues, my ip address for the WAN port was missing the subnet mask and it doesn't look like this configuration placed the switch ports up on the router. I'll update if this resolves the issue.

1 Answers1

0

Okay, so here's what I was able to find wrong with the configuration file above:

1) the configuration of interface fa0/0 was missing a mask and therefore not setting up properly

2) setting of of fa0/1/0-3 was missing a 'no shut' command and therefore they weren't coming up.

3) Vlan1 was missing a no shut command

4) I'm considering switching the default router in DHCP pool LAN to be 192.168.1.1, as this seems to better fit my experience of how DHCP pools are configured.

5) Though this resolves some issues associated with DHCP, SSH still does not appear to be working in PacketTracer, so I'll have to dive a little deeper into this.