1

I made a custom build Openwrt (barrier breaker) with Openflow 1.3 and I could connect it to ryo simple_switch_13 controller in outofband mode. Ehternet port number 3 and 4 are set as openflow ports but when I connect a device to these ports and set the IP manually it won't be able to ping 192.168.1.1 or any other device on the same network!
What is the problem here? Openflow seems to be ok and these ports work normally when they are not set as openflow ports. Please give some hints.

Config files inside openwrt are :

/etc/config/network

config switch 'eth0'                                                                
    option name 'eth0'                                                          
    option reset '1'                                                            
    option enable_vlan '1'                                                      

config switch_vlan                                                                  
    option device 'eth0'                                                        
    option vlan '1'                                                             
    option ports '1 2 8t'                                                       

config switch_vlan                                                                  
    option device 'eth0'                                                        
    option vlan '2'                                                             
    option ports '0 8t'                                                         

config interface 'loopback'                                                         
    option ifname 'lo'                                                          
    option proto 'static'                                                       
    option ipaddr '127.0.0.1'                                                   
    option netmask '255.0.0.0'                                                  

config globals 'globals'                                                            
    option ula_prefix 'fdbe:80c3:7cea::/48'                                     

config interface 'lan'                                                              
    option ifname 'eth0.1'                                                      
    option force_link '1'                                                       
    option type 'bridge'                                                        
    option proto 'static'                                                       
    option ipaddr '192.168.1.1'                                                 
    option netmask '255.255.255.0'                                              
    option ip6assign '60'                                                       

config interface 'wan'                                                              
    option ifname 'eth0.2'                                                      
    option proto 'dhcp'                                                         

config interface 'wan6'                                                             
    option ifname '@wan'                                                        
    option proto 'dhcpv6'                                                       

config interface                                                                    
    option 'ifname' 'eth0.4'                                                    
    option 'proto' 'static'                                                     

config interface                                                                    
    option 'ifname' 'eth0.3'                                                    
    option 'proto' 'static'                                                     

/etc/config/openflow file:

config 'ofswitch'
    option 'dp' 'dp0'
    option 'dpid' '000000000001'
    option 'ofports' 'eth0.3 eth0.4'
    option 'ofctl' 'tcp:CONTROLLER_IP:6633'
    option 'mode'  'outofband'

Ryu simple_switch_13 is running as the outofband controller and device is Li nksys E3000. thanks.

0 Answers0