1

I'm trying to connect (2) Cisco Catalyst 2950's over each's respective FastEthernet 0/1 ports, but for some reason, they're not communicating. I'm doing this to physically extend my network and add more network ports.

On SwitchA (10.10.10.1) I have:

!
interface Porth-Channel1
 description UPLINK
 switchport mode trunk
 switchport nonegotiate
 flowcontrol send off
end
!
interface FastEthernet0/1
 description ETHERNET-UPLINK
 switchport mode trunk
 channel-group 1 mode active
end

On SwitchB (10.10.10.2) I have:

!
interface Porth-Channel1
 description UPLINK
 switchport mode trunk
 switchport nonegotiate
 flowcontrol send off
end
!
interface FastEthernet0/1
 description ETHERNET-UPLINK
 switchport mode trunk
 channel-group 1 mode active
end

I have the same config set up on an 8-port 2960 (SwitchC), and if I plug FastEthernet 0/1 of SwitchC to SwitchB or SwitchA, it works. But if I plug FastEthernet 0/1 of SwitchB to SwitchA, it doesn't work.

Am I missing something? How do I get it so I can connect 2 Cisco 2950 switches together?

UPDATE 1

On SwitchA:

#show int port-channel 1 trunk

Port        Mode         Encapsulation  Status        Native vlan
Po1         on           802.1q         trunking      1

Port      Vlans allowed on trunk
Po1         1-4094

Port        Vlans allowed and active in management domain
Po1         1-2,5,30,112,115,120

Port        Vlans in spanning tree forwarding state and not pruned
Po1         1-2,5,30,112,115,120

On SwitchB:

#show int port-channel 1 trunk

Port        Mode         Encapsulation  Status        Native vlan
Po1         on           802.1q         trunking      1

Port      Vlans allowed on trunk
Po1         none

Port        Vlans allowed and active in management domain
Po1         none

Port        Vlans in spanning tree forwarding state and not pruned
Po1         none

For SwitchB, I've tried to add all vlans to be allowed, but it doesn't change anything:

#config t
#int port-channel 1
#switchport trunk allowed vlan all

I've also tried:

#switchport trunk allowed vlan 1-4094

But the allowed vlan's doesn't change to what I tell it to. How do I fix this?

UPDATE 2

I ran a show int po1 switchport on both switches:

SwitchA

#show int po1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Protected: false

Appliance trust: none

SwitchB

#show int po1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Protected: false

Appliance trust: none

Still no clue as to why show int po1 trunk shows Vlans allowed on trunk: none

chicks
  • 3,639
  • 10
  • 26
  • 36
CIA
  • 1,606
  • 2
  • 13
  • 30
  • `1.` What do you mean they're not communicating? How are they trying to communicate? `2.` You probably don't need the ports to be trunk ports unless you have VLAN traffic that needs to transit the two switches (for VLAN's other than the default VLAN). `3.` Have you connected a host to both switches to confirm whether or not the hosts can communicate? `4.` In their default "out-of-the-box" state it should be a simple matter of connecting the two switches with a network cable. – joeqwerty Jun 09 '14 at 17:28
  • I updated my question with the relevant information. I have vlan traffic I need to be able to get across both switches (VOIP, wifi, etc...) SwitchA has been in the environment for years. SwitchB used to be in a different area, but I was unable to get the trunking working between both switches. I have since cleared the config on SwitchB and I am here now. – CIA Jun 09 '14 at 18:00
  • Your port channel config is doing nothing since you haven't added any ports into the port channel. Showing the info on the port channel will not help us since nothing is using the portchannel anyway. If you're only using one port, you don't need a port channel at all. What VLAN's are being used and how are you testing communication? – Rex Jun 10 '14 at 18:15
  • I updated the question to reflect the change I made. I've tried both `channel-group 1 mode active` and `channel-group 1 mode on`, and neither have made a difference. – CIA Jun 10 '14 at 19:34
  • You can't add a port channel to one side and not have it configured on the other end also. Thus the reason your port channel on switch B is showing as down. Again - if you aren't using more than one port to connect the switches, there is 0 (zero, none) reason to setup a port-channel. Please post a more complete view of your switch configs somewhere and we might be able to help you better. – Rex Jun 10 '14 at 22:01
  • What does the switch log say when you connect the two switches together? – pauska Jun 10 '14 at 22:22
  • @rex the port-channel is configured on both sides. I have SwitchA already working with multiple ports on `channel-group 1` connecting to another switch already and it's working fine. It seems the problem is with SwitchB. Whether I configure it with or without the port-channel, `show int po1 switchport` on SwitchB shows my changes, but `show int port-channel 1 trunk` and `show int fa0/1 trunk` do not reflect those changes on SwitchB. – CIA Jun 11 '14 at 13:13
  • is there span monitoring setup on switch B Fa0/1 ? show int fa0/1 status – CiscoNet Solutions May 25 '15 at 02:15
  • Similar to what Phandox said. I believe the 2950's do not have auto-mdix and so you would require a Cross-over cable. Also run a `show interface status` and show us the output please – boopzz Aug 25 '15 at 21:12

1 Answers1

1

Why are you using Port-channel in first place? I don't see that there are any interfaces associated with that Port-channel.

Try adding vlans on Fa0/1.

Switch(config-if)# switchport trunk allowed vlan add 1

Also, do you have auto-MDIX turned on? If not, make sure you use crossover cables or enable auto-MDIX on interface:

Switch(config-if)# mdix auto
chicks
  • 3,639
  • 10
  • 26
  • 36
phandox
  • 101
  • 4
  • The port-channel was recommended from [Cisco](http://www.cisco.com/c/en/us/support/docs/switches/catalyst-2900-xl-series-switches/24044-172.html)'s documentation. I tried adding the vlan to Fa0/1, but no go. For some reason, the config won't update when I issue that change. I'm not sure I need a cross-over cable since I'm able to communicate properly with another switch using standard straight-through cables, but it's worth a shot. – CIA Jun 09 '14 at 18:59
  • 1
    Port-channels are used for binding multiple physical port to one logical port, increasing the bandwitch. Since you are using only one port, there is not really a need for that. On recent IOS, auto-MDIX is turned on by default, so there shouldn't be an issue, but you can try. Try also reseting the vlans. You have to delete file from flash, vlan.dat and then reboot the switch. Then check, if there is any change in vlans. – phandox Jun 09 '14 at 19:55
  • On the 2950, it looks like i don't have that option to set the MDIX to auto. I'm fairly certain now the issue is vlan related, but I don't understand why the switch won't let me add/remove vlans from a trunk. – CIA Jun 10 '14 at 15:43
  • Have you tried reseting vlans? `Switch# delete flash:vlan.dat` Don't forget to reset the switch! If nothing, at least VLANs should be in default states and you can try setting up trunk again. I think it should allow all VLANs by default on created trunk. – phandox Jun 10 '14 at 21:30
  • I deleted the vlan.dat and recreated the vlans manually, but that didn't seem to help. – CIA Jun 11 '14 at 13:09
  • For simplicity, don't use Port-Channel yet.Use `no interface Port-Channel 1`. On your SwitchB int fa0/1, make sure you have `switchport mode trunk` and disable `switchport nonegotiate` if you already hasn't. On this interface, use command `switchport trunk allowed vlan all`. Also, when you connect these two switches, how are the lights on switch lid ? – phandox Jun 12 '14 at 06:43
  • 1
    I did that and it didn't work. I came to the conclusion there was something wrong with the firmware since other switches were able to be configured with this same configuration. Thanks though. – CIA Jul 09 '14 at 20:20