2

I'm working on configuring dialout with a Cisco 2511 router and external modems. The end point is a dial-in server, which will create a ppp connection. I use this guide as a reference but it only work with async1 port, when I switch to async2 and ping the server, the router doesn't dial the server.

Config: client computer==(ethernet)router==(async port)modems----pstn----modem==dial-in server(s)

Can someone help me out of this? A detail answer or document will help me much since I'm new with this things.

Update: the result of sho run

!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname Cisco
!
!
chat-script dialnum ABORT ERROR ABORT BUSY "" "ATD\T" TIMEOUT 180 CONNECT
chat-script DialOut ABORT ERROR ABORT BUSY "" "ATD\T" TIMEOUT 120 CONNECT
modemcap entry Zyxelsetup:MSC=&FS0=1&K4&N70
modemcap entry hayes:MSC=&FS0=1&K4&N70
modemcap entry Mosetup MSC=&FS0=1+MS=11,1,19200,19200
!
interface Ethernet0
 description !!----- LAN interface -----!!
 ip address 192.185.10.254 255.255.255.0
 ip access-group 100 in
 ip access-group 100 out
 no ip mroute-cache
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Async1
 no ip address
 encapsulation ppp
 async mode dedicated
 dialer in-band
 dialer rotary-group 0
!
interface Async2
 no ip address
 encapsulation ppp
 async mode dedicated
 dialer in-band
 dialer rotary-group 1
!
interface Dialer0
 ip address 192.184.10.254 255.255.255.0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 180
 dialer string xxxxxxx
 dialer-group 1
 ppp chap hostname CISCO1
ppp chap password 7 0010161510
!
interface Dialer1
 ip address 192.184.9.254 255.255.255.0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 60
 dialer string xxxxxxxx
 dialer-group 1
 ppp chap hostname CISCO2
 ppp chap password 7 110A11001419
!
ip classless
ip route 192.184.9.0 255.255.255.0 Dialer1
ip route 192.184.10.0 255.255.255.255 Dialer0
access-list 100 permit tcp any any
access-list 100 permit icmp any any
access-list 100 permit ip any any
!
dialer-list 1 protocol ip list 100
!
line con 0
line 1 16
 script dialer DialOut
 modem InOut
 modem autoconfigure discovery
 speed 115200
 flowcontrol hardware
line aux 0
line vty 0 4
 login
!
end

Thank you!

Tiana987642
  • 131
  • 2
  • 6

1 Answers1

0

Which server did you ping? You need to ping 192.184.9.X to use your async2.

Configuration looks fine, same config on async1 an async 2 no reason asyn2 not working.

Do a debug ppp and debug dialer and let us see.

ncs
  • 1
  • Hi, I ping the addresses in the dialer profiles (after change the async line), I can't provide an exact log file right now, but I remember the `debug modem` stop at `asserting dtr...`, It seem something is wrong with the line, my friend suggest maybe it's the modemcap. Change it to `type hayes` make the call happens, but I can't ping the server. I'm still working it out! – Tiana987642 Oct 02 '13 at 15:27
  • This is better as a comment. Once you have enough reputation you will be able to comment on posts – Dave M Oct 02 '13 at 15:36
  • Oh! If it stops at asserting DTR (raising the "data terminal ready" flag to the modem), it sounds like perhaps negotiation is failing, or the modem interface card is faulty. Or, indeed, the modem is just confused, since you say `type hayes` makes it get past that point. – Falcon Momot Oct 03 '13 at 09:10
  • Thank all, finally, it works! I can't tell the exact reason, maybe the problem is the router itself. It just locked me out yesterday even I entered the correct password(a cold reboot fixed it). The "magic word" is a mistyped command, then it starts `Translating "xxxx"...domain server` and woo hoo, all the modems start to dial. Really weird! – Tiana987642 Oct 05 '13 at 08:49