1

I have an office downstairs which requires approximately 500 feet of cat-5 to reach. We have a basic L2 switch in a closet at the halfway point which acts as a signal booster, and allows us to give connectivity to the downstairs office. This all worked fine until I wanted to use two runs instead of one, in order to give extra bandwidth and fault-tolerance to the connection. I was told on the Cisco Support forums that I could still use the same basic L2 switch at the halfway point if I use EtherChannel, and everything would work. This doesn't make sense to me... how could you avoid the network loop there? I've tried it, and sure enough, I get colliding packets due to the network loop it creates. STP kicks in and tries to correct it, but it doesn't seem to work, and all I get is chaos.

OK, so I was really skeptical that having a plain old L2 switch at the halfway point would work, and indeed, it seems this is the case. Is there a way to do this? Or perhaps this should work, but I've misconfigured something?

To me, it seems more logical to have another L3 switch to match the two I have on the endpoints, and configure it with two sets of EtherChannels, each of which connects to one of the other endpoint pairs.

Anyway, the question is, can I do EtherChannel over two hops, and if so, how? I'd just experiment, but its a pain to coordinate with building management to open up that closet, so I'd like to know what I'm doing beforehand.

Here's my config and other info:

  • (2x) Cisco sg300 switches (in L3 mode), one at each endpoint

  • (1x) Cheapo L2 smart switch, hereafter referred to as "the booster switch"

  • I'm using PaGP on the endpoints, not LACP

  • (2x) CAT-5 runs of less than 300' go from one endpoint to two of the ports on the booster switch, and then (2x) more runs of less than 300' go from two more ports of the booster switch to the other endpoint.

  • Cisco config here (private and unneeded details removed):

    sw-sg300-10-454#show running-config
    config-file-header
    sw-sg300-10-454
    v1.2.7.76 / R750_NIK_1_2_584_002
    CLI v1.0
    file SSD indicator encrypted
    @
    !
    no cdp run
    vlan database
    vlan 2-4
    exit
    port-channel load-balance src-dst-mac-ip
    hostname sw-sg300-10-454
    !
    interface vlan 1
     ip address 192.168.5.23 255.255.255.0
     no ip address dhcp
    !
    interface vlan 2
     name data
    !
    interface vlan 3
     name voice
    !
    interface vlan 4
     name wireless
    !
    interface gigabitethernet1
     switchport trunk allowed vlan add 4
     switchport trunk native vlan 2
    !
    interface gigabitethernet2
     switchport trunk allowed vlan add 4
     switchport trunk native vlan 2
    !
    interface gigabitethernet3
     switchport trunk allowed vlan add 4
     switchport trunk native vlan 2
    !
    interface gigabitethernet4
     switchport trunk allowed vlan add 4
     switchport trunk native vlan 2
    !
    interface gigabitethernet5
     switchport trunk allowed vlan add 4
     switchport trunk native vlan 2
    !
    interface gigabitethernet6
     switchport trunk allowed vlan add 4
     switchport trunk native vlan 2
    !
    interface gigabitethernet7
     channel-group 1 mode on
    !
    interface gigabitethernet8
     channel-group 1 mode on
    !
    interface Port-channel1
     description to_other_endpoint
     switchport trunk allowed vlan add 2-4
    !
    sw-sg300-10-454#
    

Thanks for any pointers.

sbgoodwin
  • 123
  • 1
  • 1
  • 8
  • 3
    Maximum run length for ethernet is not a matter of signal strength, it's packet transit time. If you exceed your maximum length, then a small packet can be 100% "in flight" on the wire, and the CSMA/CD algorithm in Ethernet is built on the assumption that this will never happen. Packet-collision chaos ensues. – tylerl May 14 '13 at 23:46

2 Answers2

3

If I wanted to connect two offices, that are 500ft apart, I'd use Fibre. Couple of decent HP or Cisco switches at either end, Fibre 1Gbit GBICs, job's a good-un. Instead of trying to do it in a single stretch of copper, with some switch in a broom cupboard.

Ask yourself this, how much do you get paid? Figure out how much this "solution" is costing you, and the cost of the downtime if (when!) it all goes wrong, and then cut your losses, buy some decent hardware and do it properly.

Oh, it just occurred to me, there's also Point-to-point wireless links, and free-space optics, if you've got line-of-site between your two offices.

Tom O'Connor
  • 27,440
  • 10
  • 72
  • 148
  • For what it's worth, Cisco Small Business products aren't in my list of decent Cisco switches. – Tom O'Connor May 14 '13 at 23:29
  • I'm not going to rework the entire infrastructure of my network over this issue... The solution mentioned by techieb0y sounds like it'll do the trick with a /lot/ less effort than your solution would require. Thanks anyway though. – sbgoodwin May 14 '13 at 23:37
  • well you're just a barrel of helpful fun. I work for a very small company, so don't worry, it sounds like you're "above" that. – sbgoodwin May 14 '13 at 23:41
  • Some people thrive on unhelpful insulting answers... and life goes on without them. :) – Robert Novak May 14 '13 at 23:46
  • Also, the two offices are in the same building, so line of sight through walls/floors isn't so easy to work out, I'd guess. – Robert Novak May 14 '13 at 23:47
  • 1
    @TomO'Connor: Just so we're clear, I agree that your suggestion is superior in concept. The reality, however, is that running fiber is simply not possible right now, for several reasons. If you really want me to list the reasons, PM me or something, and I guarantee I'll convince you to agree with me. – sbgoodwin May 15 '13 at 18:17
  • I can't pm you, but email me at the email address in my profile. I'd be interested to hear your reasons. – Tom O'Connor May 16 '13 at 08:21
1

The booster switch need not be L3-capable to work with an EtherChannel bundle, but it does need to be a managed device and support the same protocols (LACP or PAgP) as the other switches on the ends. Just configure one bundle going up, and one going down. Ensure that the booster switch's VLAN database and trunk allowed vlans match the ends, and you should be all set.

techieb0y
  • 4,161
  • 16
  • 17
  • 1
    Well that was quick, thanks! I'll update this post when I verify a working config -- but so far, this sounds good. – sbgoodwin May 14 '13 at 23:39
  • So you're saying no need to specifically configure any port-channels on the booster switch, right? Just make sure vlan database and trunk settings are correct? Then I'd take the two lines from upstairs port-channel and the two from the downstairs, and just plug them in to any ports on the booster switch? – sbgoodwin May 15 '13 at 18:29
  • No, the booster switch would need to be configured. Top switch has Po1 going down to the booster switch, bottom switch has po1 going up to the booster switch, booster switch has po1 up and po2 down. – techieb0y May 17 '13 at 00:09
  • You mean "bottom switch has **p02** going up" I'm guessing, right? Excellent, thanks for the clarification -- I'll give it a try early next week and report back. – sbgoodwin May 17 '13 at 22:04
  • Po2 would work too; the numbering is arbitrary. The top and bottom switches have one port-channel interface each; only the central booster switch has two. The interface numbers need not match on both ends of a segment. – techieb0y May 18 '13 at 00:28