On a FreeBSD system (8.1), I am looking for instructions on how to check the running version of OpenSSH and also instructions on the best way to download install an update of OpenSSH
4 Answers
Run sshd -V
or ssh -V
and they'll return the version and usage information.
Note: These are capital "V" now, when I originally wrote this answer they were lower case.
There's a dozen ways to upgrade.
pkg-add -r openssh-portable
cd /usr/ports/security/openssh && make install clean
portupgrade security/openssh-portable
- part of the makeworld/buildworld process
- freebsd-upgrade
- and the list goes on...
I'm not aware of any issues with the 5.2p1 version that shipped with 8.1-RELEASE. I have seen hoax e-mails flying around for over a year now announcing the imminent release of a zero day hack (note that it's been a year and a half since release, so 'zero' day was a heck of a long time ago).
- 77,337
- 11
- 120
- 212
-
Agree with everything, except 8.1-RELEASE has OpenSSH 5.4p1. – hmallett Dec 16 '10 at 20:56
-
1I needed to use `ssh -V` (note capital v) as on my system (and I thought this was standard) the `-v` option is used for verbose (iirc). – Mike H-R Nov 13 '14 at 10:38
-
@MikeH-R Thanks, not sure when it changed, but it's definitely capital V now. – Chris S Nov 13 '14 at 14:44
telnet localhost 22
Why do you want to upgrade OpenSSH? It's part of the core system and is usually upgraded with the system.
- 2,383
- 5
- 32
- 54
-
-
Awesome answer. Exactly what I was looking for. I always run the daemon – benathon Jan 27 '14 at 21:12
How to find openssh version on a Linux or Unix-like system?
The syntax is as follows to find openssh version on a CentOS/RHEL/SL:
# yum list installed openssh\*
The syntax is as follows to find openssh version on a Debian/Ubuntu Linux:
$ dpkg --list | grep openssh
### OR ###
$ dpkg --list openssh\*
- 495
- 1
- 5
- 11
Try running:
which sshd
If that prints /usr/sbin/sshd, then it's probably installed as a package. In that case, you can check the installed version using:
pkg_info | grep ssh
or:
pkg_info -W `type sshd`
And I think you update it using:
pkg_add -r openssh-portable
but read the FreeBSD Guide to the Packages System first, because I haven't done that in a long time and it might have changed.
If
which sshd
prints /usr/local/sbin/sshd, then it's probably installed as a port.
Read up on how to upgrade it in the Guide to Using the Ports System. The port name is security/openssh-portable, i.e. /usr/ports/security/openssh-portable.
- 3,727
- 2
- 19
- 16
-
1Of course, if you really wanted the running version rather than the installed version, you could also try "telnet localhost 22", and look for the version number. The version number is the second number, i.e. the number after "OpenSSH_". – Mikel Dec 16 '10 at 11:36
-
See also http://www.geekvenue.net/chucktips/jason/chuck/1044986336/index_html – Mikel Dec 16 '10 at 11:53