Two Devices, Same Subnet, No Communication

7

This is a stripped down version of my home network, and my problem is I can not get 192.168.20.100 to communicate with 192.168.20.4.

The workstation pings both routers and the server fine, and can communicate with both. Its gateway is set to 192.168.20.1.

The server pings only the workstation and router 192.168.20.1 fine, and has 100% packet loss to 192.168.20.4, despite having it set as its default gateway.

I purposely want the server to use 192.168.20.4 as the default gateway and the rest of the network to use 192.168.20.1, but I wanted to keep them both on the same subnet.

I will say this problem began when I swapped out using multiple 4 port switches for the 2950 switch, but I'm not sure how that would have caused this problem.

No DHCP present, this is all static.

Home Network Diagram

Workstation ARP:

192.168.20.4             ether   00:1d:73:55:31:7a   C                     eth0
192.168.20.100           ether   90:e2:ba:27:5f:3a   C                     eth0
192.168.20.1             ether   00:24:a5:42:a7:dc   C                     eth0
192.168.20.5             ether   00:0e:84:06:73:40   C                     eth0

Server ARP:

192.168.20.4             ether   00:1d:73:55:31:7a   C                     eth0
192.168.20.101           ether   6c:f0:49:0a:91:82   C                     eth0
192.168.20.5             ether   00:0e:84:06:73:40   C                     eth0
192.168.20.1             ether   00:24:a5:42:a7:dc   C                     eth0

Switch ARP:

Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.20.100          0   90e2.ba27.5f3a  ARPA   Vlan1
Internet  192.168.20.101         10   6cf0.490a.9182  ARPA   Vlan1
Internet  192.168.20.4            9   001d.7355.317a  ARPA   Vlan1
Internet  192.168.20.5            -   000e.8406.7340  ARPA   Vlan1
Internet  192.168.20.1            1   0024.a542.a7dc  ARPA   Vlan1

Switch MAC Address Table:

1    001d.7355.317a    DYNAMIC     Fa0/3
1    0024.a542.a7dc    DYNAMIC     Fa0/24
1    6cf0.490a.9182    DYNAMIC     Gi0/2
1    90e2.ba27.5f3a    DYNAMIC     Gi0/1

Running Config (Sanitized):

Current configuration : 1313 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Europa
!
enable secret 5 .............................
!
ip subnet-zero
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!         
interface FastEthernet0/17                                                                             
!                                                                                                                   
interface FastEthernet0/18                                                                                                 
!                                                                                                                                  
interface FastEthernet0/19                                                                                                                 
!                                                                                                                                                 
interface FastEthernet0/20                                                                                                                              
!                                                                                                                                                                  
interface FastEthernet0/21                                                                                                                                                      
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 192.168.20.5 255.255.255.0
 no ip route-cache
!
ip http server
!
line con 0
line vty 0 4
 password .........
 login
line vty 5 15
 password .........
 login
!
!
end

EDIT

I can't answer my own question yet, but I have found the problem. 192.168.20.4 had an incorrect ARP entry the server. Thank you for mentioning checking the ARP tables, I feel dumb for not checking the routers as well.

Jeff

Posted 2014-03-02T19:19:33.687

Reputation: 245

Answers

2

I have found the issue. 192.168.20.4 had an incorrect ARP entry for 192.168.20.100. Thank you for mentioning checking the ARP tables, I feel dumb for not checking the routers as well.

Jeff

Posted 2014-03-02T19:19:33.687

Reputation: 245