How can I remove BlackBerry tools, entirely, from OS X?

11

4

I used BlackBerry's Desktop Manager and several other apps and tools to develop BlackBerry applications, but now I'd like to remove them all, entirely.

To do so, I dragged the BlackBerry applications from /Applications to the Trash, and I also removed the preferences under ~/Library/Preferences starting with com.rim. – however still, there are several processes related to BlackBerry running. I have no idea where they come from and how to disable them.

What can I do to remove all things BlackBerry from my machine?

slhck

Posted 2013-09-19T21:22:22.013

Reputation: 182 472

7

For the person who downvoted, note that we explicitly encourage sharing information this way: It’s OK to Ask and Answer Your Own Questions

– slhck – 2013-09-19T21:30:52.603

Answers

12

BlackBerry's tools are scattered all over the file system and aren't easy to remove. I found a shell script that should remove most of it and put it here as a Gist. If you know what you're doing you can run it under root privileges.

If you want to do it manually instead, you can try the following:

  • Remove all apps from /Applications
  • Remove all login items from Users & Groups » Login Items under System Preferences.
  • Remove the BlackBerry virtual machines from ~/Virtual Machines if you have some.

Now, open up a terminal and enter the following commands. Best to copy-paste them. You don't want to do something wrong here or else you'll delete important system files. Having a backup of your system is always preferred.

First unload some LaunchAgents and LaunchDaemons:

sudo launchctl unload /Library/LaunchAgents/com.rim.BBLaunchAgent.plist
sudo launchctl unload /Library/LaunchDaemons/com.rim.BBDaemon.plist

Those are the startup files for the above that run every time you start OS X:

sudo rm -rf /Library/LaunchDaemons/com.rim.*
sudo rm -rf /Library/LaunchAgents/com.rim.*

Now we remove kernel extensions and frameworks:

sudo kextunload -b com.rim.driver.BlackBerryUSBDriverInt
sudo rm -rf /System/Library/Extensions/BlackBerryUSBDriverInt.kext
sudo rm -rf /System/Library/Extensions/RIMBBUSB.kext
sudo rm -rf /System/Library/Extensions/RIMBBVSP.kext
sudo rm -rf /Library/Frameworks/RimBlackBerryUSB.framework

Preferences of all sorts:

sudo rm -rf "/Library/Application Support/BlackBerry"
sudo rm -rf "/Library/Application Support/BlackBerryDesktop/"
sudo rm /Library/Preferences/com.rim.*

rm -rf "~/Library/Application Support/BlackBerry"
rm -rf "~/Library/Application Support/BlackBerryDesktop/"
rm ~/Library/Preferences/com.rim.*

I think that's about it. Now I have no more BlackBerry stuff running on my system.

slhck

Posted 2013-09-19T21:22:22.013

Reputation: 182 472