Disabling the command enter shortcut on Mac Entourage


It seems like disabling a shortcut should not be such a big deal, but I cannot seem to be able to do it for any shortcuts and specifically not for the combination that I keep hitting by mistake, every single day. The smaller space bar makes it very easy to hit the command key by mistake, and the return is a commonly used key when typing. I keep sending important e-mails before I am done typing, or worse, before I am done editing. I do not necessarily want to disable all the shortcuts, but that one for sure. The choices for changing anything in Entourage seem very limited. [Entourage for Mac 2008. Version 12.2.8. (101117) ESD] It is easy enough just to hit "send." This short cut causes a lot more trouble than it saves. Help.


Posted 2011-03-14T14:56:14.790

Reputation: 1



Many key-based “launcher” applications will capture keystrokes before normal applications get a chance to “see” them. You could assign ⌘↩ (Command-Enter) in once of those launchers to prevent Entourage from seeing it. Some launchers even let you assign shortcuts that are only active with certain applications.

John Gruber has described using FastScripts to reassign Mail’s ⌘R to an AppleScript program that moves the insertion point out of “top posting” position.

In your case, the AppleScript could be completely empty since you just want to ignore the keystroke.

Here are the step-by-step instructions.

  1. Start FastScripts.
  2. Activate Entourage (make it the frontmost application).
  3. Click FastScripts > Create Entourage Scripts Folder from FastScript’s menu icon on the right-hand side of the menu bar (its icon looks like a black scroll with the ends curled over and under and a lightening bolt on the smooth section).
    The Entourage part of the menu item label might be different, use the only menu item that labeld like “Create appname Scripts Folder” (do it while Entourage is frontmost though).
    This will open a new Finder window for the new folder. Leave it open and off to one side for now.
  4. Activate AppleScript Editor.
  5. If an empty document did not come up automatically, use File > New (⌘N) to get an new, empty document.
  6. Use File > Save As… (⇧⌘S) to save the empty AppleScript program.
  7. Click and hold, then drag the icon from the title bar of the Finder window to anywhere in the Save As “dialog” in AppleScript Editor.
    This will “move” the dialog into that folder. Or, you could use the controls in the “Save As” panel to navigate to the directory manually.
  8. For “File Format”, be sure “Script” is selected.
  9. Type in a name for the script (e.g. do nothing).
  10. Click “Save”.
  11. Click FastScripts > Preferences… from FastScript’s menu icon on the right-hand side of the menu bar.
  12. Choose the Script Shortcuts “tab”.
  13. Click the right-pointing disclosure triangles in the list of scripts until you find your new script (start with /Users/<yourname>/Library/Scripts, then Applications, finally Entourage).
  14. Double click the “(none)” in the Shortcut column next to your saved script.
  15. Type Command-Enter (⌘↩) to enter the shortcut.
  16. Activate Entourage and get to a point where you can use Command-Enter (⌘↩) (compose an email to yourself?). Try the keystoke. Hopefully, it should now “do nothing” (FastScript should “eat” it and run the script that does nothing instead of letting the keystroke get to Entourage).

Chris Johnsen

Posted 2011-03-14T14:56:14.790

Reputation: 31 786

Ugly hack but a great idea. If only it didn't require a paid program; while I recommend them myself, it seems a bit too much for this issue. It might work with the still free Butler by Manytricks. – Daniel Beck – 2011-03-15T19:39:30.567

@Daniel: FastScript is free for up to 10 shortcuts for as long as you want it. Is the free version of Butler hidden away somewhere? I only see “free trial”. – Chris Johnsen – 2011-03-15T22:35:27.170

I found the explanation for my confusion over free vs. trail Butler: v4 used to be free with an optional donation, now v4 is still free, but you can pre-purchase a license for v5 buy “buying v4”.

– Chris Johnsen – 2011-03-15T22:51:38.843

Anyway, I tried Butler and it also seems to be as effective at hiding keystrokes from applications (the configuration seems more complicated to me—though obviously more powerful, too). My first paragraph referred to generic ‘“launcher” applications’; I suspect that many other keystroke grabbing apps will also work. – Chris Johnsen – 2011-03-15T22:54:30.260

Thank you everyone for your help on this. It seems quite hard for a moron like me to do this. First I need download a program (free, I understand for 10 keystrokes). Then I need to go into AppleScript Editor, which I would normally never go near, and enter that command, right? The command starts with ~. Then I need to figure out what Entourage calls itself. Isn't it "Entourage?" Then save it. Then I use the FastScripts program to assign command-enter to the saved program? Can't I just click "disable" some place? – Bruce – 2011-03-16T05:32:51.377

@Bruce That ~ denotes your home directory. It just means, open Finder, then open Library, then Scripts (creating if it doesn't exist yet), then Applications (also creating if necessary), etc. -- As Chris doesn't own Entourage he has to guess the name of the Entourage application, either as it appears in Finder or at the top left of the menubar when running -- it could also be "Entourage 2008", so you'd need to substitute that. – Daniel Beck – 2011-03-16T06:28:37.820

@Bruce: updated with step-by-step instructions; there should be no guessing or trial-and-error involved in naming the folder now (I remembered that FastScripts has a command to make the appropriately named folder for whatever application is frontmost). – Chris Johnsen – 2011-03-17T10:16:52.233


Shortcuts aren't generally managed by individual applications, but instead from System Preferences > Hardware > Keyboard > Keyboard Shortcuts. Try adding an Application Shortcut for Entourage which maps Command-Enter to something safe like "save draft".


Posted 2011-03-14T14:56:14.790

Reputation: 10 195

Fun fact: Setting keyboard shortcuts this way utterly fails for Office 2011 (adding a shortcut generally works, changing it works sometimes, seemingly random, and clearing it leads to really broken behavior). I don't think the Microsoft folks cared more about OS X integration in 2008, but the user could be lucky. – Daniel Beck – 2011-03-15T18:53:26.520

That was my main worry, yes. There isn't a while lot the OP can do if that's the case, though. – geekosaur – 2011-03-15T18:57:09.600

Thank you very much for your help on this as well. This did looklike an easy and good solution. I had no idea that the shortcut was not related to the application, but to the system. But, I tried it, and it did not work. Was I just supposed to type "save draft" or ""save draft"" ? I tried both. Could I enter something else in there, like just a blank, or, some other command? Any ideas? I had one more reply that might work, but it seems overly complicated (scary, as in I might break more than I fix) for me to try. Thanks again for the info. If any more ideas please let me know. – Bruce – 2011-03-16T05:37:39.033

OS X looks for a menu item with the specified title, so you'll need to determine that (I don't have Entourage, sorry). – geekosaur – 2011-03-16T05:57:19.257

1@Bruce You cannot break anything with assigning a custom keyboard shortcut that cannot be easily fixed by removing it again and restarting affected applications. Don't let my comment discourage you: If it doesn't work right, simply undo what you did with the shortcut assignments. – Daniel Beck – 2011-03-16T06:29:52.843


I've fought with this for a while and found that what you have to do is to break the original shortcut for "Send".

Go to System Settings -> Keyboard -> Keyboard shortcuts -> Application Shortcuts.

Now add Outlook/Entourage to the list and make sure that "Menu title" states "Send". After that choose whatever cryptic shortcut you are sure you will never accidentally hit.

That did it for me in Outlook 2011.


Posted 2011-03-14T14:56:14.790

Reputation: 31

while it's fine in this case (both those posted so far seem to be helpful), we generally discourage copy-pasting of answers across different questions. And also please note that we don't want signoffs and signatures are, so please avoid these in the future.

– DMA57361 – 2011-06-23T09:49:48.290