Failing to extract a tar/bz2 file


File in question is

meder@pc:~$ tar -xvjf wkhtmltopdf-0.10.0_rc2-static-i386.tar.bz2 
bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Error exit delayed from previous errors

I tried to unzip it as well, and I tried a various slew of commands to no avail on my Debian box which has no GUI.

I downloaded this on my local desktop ( Ubuntu ) and was able to easily extract w/ my mouse so I'm not exactly sure what the extractor did differently...

meder omuraliev

Posted 2011-02-13T09:50:58.750

Reputation: 1 609



What does file tell you? It may have been uncompressed why you downloaded it. If so, it's just not compressed at all.


Posted 2011-02-13T09:50:58.750

Reputation: 7 263

wkhtmltopdf-0.10.0_rc2-static-i386.tar.bz2: bzip2 compressed data, block size = 900k – meder omuraliev – 2011-02-13T09:54:05.780

interesting.. i just did tar -xvf and that seemed to extract it.... – meder omuraliev – 2011-02-13T09:54:54.563

Son of a.. I seemed to have wget'd a 404/hotlink page instead of the actual file. Thanks and accepting asap. – meder omuraliev – 2011-02-13T09:55:51.177