How to remove one or all auto-complete text entries in Chrome?



Possible Duplicate:
Remove auto-complete field entries in Google Chrome

Ok... so this is embarrassing.

I typed in "boobs" on EncyclopediaDramatica's search because, well, it's a really funny page.

But now I've got a problem... EVERY TIME I click a search feild in Chrome now, it shows "boobs" as the first suggestion in the drop down!

This is not really socially acceptable as this laptop goes with me everywhere and Chrome is my primary browser.

Is there a way I can isolate and remove just that one entry?


Posted 2010-08-12T19:49:48.933

Reputation: 4 601

Question was closed 2010-08-12T23:00:27.030

2This has been marked as duplicate but the original is not linked. @heavyd please provide this link, as I cannot post the correct answer to this question – William Entriken – 2015-07-28T16:07:40.593

1On my macbook fn+shift+delete does the job of removing a single entry from the drop down. – Dirk Schumacher – 2017-04-30T19:48:28.393

This has been marked as a duplicate, but the linked question is for something that is different, though related question. – jvriesem – 2019-01-29T18:48:09.090

47BTW, Chrome has incognito mode for these kinds of searches... :-P – opyate – 2012-04-27T11:19:40.343

177Kayle, I bet when you wrote this you didnt think you would show up as the first result when googling "chrome delete autocomplete". Congratulations on forever being the boob autocomplete guy! – Jeff – 2013-03-05T15:23:05.430

22@Jeff This brought me to tears. You can delete auto-complete but you can never stop being the boob auto-complete guy. – George Reith – 2014-04-05T12:08:01.283

8Hah! I really don't mind. I meant to be humorous when I pushed this. I had no idea it would become such a popular question though! – Garrett – 2014-04-05T17:38:01.397



Linux and Windows

Just highlight it in the dropdown list (using the arrow keys, or your mouse cursor) and press delete on your keyboard.

Note that you may have to press shift+delete in some cases, like if the autocomplete is in the address bar (URL) field.


  1. Start typing so that the unwanted autocomplete URL comes up.

  2. Hit fn+shift+backspace if you have a compact keyboard or shift+delete ⌦ if you have a keyboard with separate delete ⌦ key (and no fn). If you have a non-Apple keyboard, shift+delete should do the trick.

If it still doesn't work:

  1. Close the page and reload it; it should now be removed from autocomplete;

  2. Check if the unwanted URL is in your bookmarks; once removed from bookmarks, it will disappear from autocomplete.


Posted 2010-08-12T19:49:48.933

Reputation: 20 970

On my MacBook Air (with fn and a key marked 'delete' which works as backspace and removes the character to the left of the cursor) I got it to work by pressing fn+shift+delete. Hooray! – LarsR – 2014-09-06T17:13:19.330

45This doesn't work anymore. – Jason – 2015-01-15T22:30:35.413

1+1 for shift + delete on Ubuntu linux to remove username autocomplete. – rogeriolino – 2015-09-30T13:50:39.160

2For German keyboards: shift + entf – Luca Steeb – 2015-12-18T22:36:43.943

6shift + delete also works on Windows! A tiny step towards getting my sanity back. – GaTechThomas – 2015-12-31T15:58:13.407

4+1 for fn+shift+delete on Macbook Pros! – Kelseydh – 2016-05-31T23:06:33.060

4This still works! However, my problem is that my bookmarks are coming up in the dropdown, so that might also be the problem for people who thought that this doesn't work anymore. – silvenon – 2016-08-05T09:09:01.730

2To me it does not work. Entries either can not be deleted or they keep coming up again like @silvenon mentions. – Langhard – 2016-09-14T14:47:28.890

I thought all hope was lost for me on my MacBook using Chrome. I just could not get it to remove a specific autofill suggestion. I had tried all manor of key combination above with no success, UNTIL I tried FN-SHIFT-DELETE from my MacBook Pro keyboard directly (instead of using my bluetooth keyboard) and guess what, it worked. What sweet relief! So, for MacBook users...make sure you are using the FN-SHIFT-DELETE on the built-in keyboard. – John Mark Mitchell – 2016-12-05T20:39:28.667


If this doesn't work for you, the auto-complete suggestion may be coming from your history. Clear it there too.

– reergymerej – 2016-12-29T14:46:32.600

3Note! On a Mac this has to be shift-forward delete (i.e. delete ⌦). fn-delete (i.e. fn-backspace) is how you type a forward delete on a laptop/small keyboard, hence fn-shift-delete on those keyboards. The mixed up terminology is confusing, especially since both keys are labeled "delete" on the Mac. – devios1 – 2017-02-02T19:29:07.793

About Shift+Del not working, I didn't noticed the autocompleted result I was attempting to delete was bookmarked -__- Yes I feel silly, I didn't noticed the star icon! (A corporate website changed it's IP and I wanted to delete the old IP from results) Verify if this applies to you. – Metafaniel – 2017-04-20T17:23:43.133

3For mac users struggling with this on login forms with autocomplete, fn+shift+delete won't work. You need to go to chrome://settings/passwords and remove it manually for the site. – Seth Jeffery – 2017-07-21T13:47:36.853

2For mac users, don't bother with that delete or whatever key combinations anymore. As @SethJeffery suggested, just go to chrome://settings/passwords and remove from there. No other way now in 2017 as far as i tried. – 夏期劇場 – 2017-10-16T08:13:13.510

Somewhat relevant: If you want to "append" keywords and jump to the end of the autocomplete suggestions, press Ctrl-e or Ctrl-a to prepend keywords and jump the cursor to the beginning of your keyword search terms on the Omnibar URL box. The usual scroll through word by word using Alt/Option-Shift-Arrow also works on my Mac too. – Tony Barganski – 2018-10-01T20:38:05.943

FYI: fn+shift+delete worked on my 2014 MBA with latest Chrome today. – Jonathan Cross – 2018-10-28T14:02:21.653

1I can confirm that fn + shift + backspace works on MacBook Pro 2017 on Chrome 71 - it successfully deletes the suggested url. – Liran H – 2018-12-20T16:59:51.557

2For those saying that it doesn't work, make sure that it is not buried in your bookmarks folder somehow. This did not appear to work for me (MBP 2013, using Chrome 71) until I discovered that they were in my bookmarks folder. As soon as I removed them (just now!), the <kbd>shift</kbd>+<kbd>delete</kbd> step worked like a charm. – jvriesem – 2019-01-29T18:54:48.833

Sometimes works, other times just makes my touch bar do a little dance, but not delete. – Ray – 2019-03-01T14:11:08.477

Actually, some urls will be deleted, others won't. Can't seem to determine a path to repeat either consistently. – Ray – 2019-03-01T14:18:54.453

3DOES NOT WORK ON MAC ANY MORE! – e_x_p – 2019-03-10T19:36:07.920

1does not work on mac os 10.14.5 and chrome 75.0.3770.100 today. – Henning – 2019-07-09T13:29:06.447

Does not work on Windows 10 using Chrome Version 76.0.3809.132 (Official Build) (64-bit) on a computer with physical Delete and Backspace keys. – George – 2019-09-08T20:23:06.107

NB: you can't delete suggestions that are bookmarks. Remove the bookmark instead. – tekumara – 2019-12-02T05:53:37.097

22Please don't confuse delete and backspace. No keyboard I know contains both fn and delete. fn-backspace means delete. – rjmunro – 2012-07-04T10:52:32.890


@rjmunro Maybe the terminology is mixed up, but just wanted to point out that the keyboard on my MacBook Air definitely has both a fn and a delete key.

– brandonjp – 2012-10-03T19:58:48.843

@brandonjp Does it have a backspace key? What country is your keyboard from? – rjmunro – 2012-10-04T10:26:42.827


@rjmunro No key is explicitly labelled as backspace, that's why I think it's a 'terminology' issue or Mac/PC variance... My MacBook Air (13-inch, Late 2010) and my Apple Bluetooth Keyboard perform a backspace/backward-delete when the delete key is pressed. Pressing fn + delete performs a forward-delete. Also, both are from the U.S.

– brandonjp – 2012-10-04T16:18:18.243

2@brandonjp Your terminology is mixed up. The key marked with an arrow like this <-- is backspace, not delete. Delete actually has the word "Delete" written on it (or sometimes just Del on non apple keyboards). Backspace deletes backwards. Delete deletes forwards. Where no delete key is available, Fn-backspace does delete. – rjmunro – 2012-10-05T16:12:35.480

3@rjmunro Right, fully understand what you're saying, but on the US Apple keyboard (see pictures linked previously) there is no key labelled "backspace" or "<--" However, there is a key that actually has the word "delete" on it and, when pressed, performs a backspace (so in this case... Delete deletes backwards). – brandonjp – 2012-10-19T01:39:55.893

1@brandonjp: Jonathan Ive probably thinks that the world 'delete' for more aesthetically pleasing than 'backspace', so decided to break with convention. He seems to value aesthetics above functionality, ergonomics or practicality. – paradroid – 2012-10-19T01:52:12.713

Wow that is seriously screwed up. These are the UK keyboards: large, small. What does a US large keyboard call the real delete key?

– rjmunro – 2012-10-19T11:02:25.160

15@rjmunro You're dating yourself - MacBook Pros have both the "delete" key and the "fn" key. – D Mac – 2012-12-26T22:12:41.757

37@DMac Macbook pros do not have a delete key. They have a backspace key, but in the US version only, the word "delete" is written on it. It still works as a backspace key, and you still have to use the fn key to get it to work as a delete key. – rjmunro – 2012-12-31T00:22:57.437

14I am trying Fn+Shift+Delete on a US MBP and it does nothing to the suggested item. I tried removing it from the full history after searching for it, but it is still there (ie., if I search again it still shows up in the search results). – haridsv – 2013-02-19T06:27:26.323

Will this delete all autocomplete entries on all sites, or will it only delete some of them? – Anderson Green – 2013-04-12T03:28:22.120

@AndersonGreen It is per site per textbox. – seekerOfKnowledge – 2013-08-14T12:04:39.717

4It's shift+delete on Ubuntu Linux as well – Mladen Danic – 2014-06-05T11:04:29.637

1I am having the same problem as @haridsv. Has this changed recently? – Guillochon – 2014-06-17T16:16:29.920