A process is sending some command to an uninstalled program every ten seconds

0

1

A while ago I installed Steam on my Mac... It was a failed attempt as my computer is way too slow to play Portal, so I uninstalled it using AppZapper (I believe). I was doing some computer maintenance and took a look through my logs; I noticed that every ten seconds in console I get this:

Sender[PID]

com.apple.launchd.peruser.501[90]

Message

(com.valvesoftware.steam.ipctool[nnn]) posix_spawn("/Applications/Steam.app/Contents/MacOS/osx32/ipcserver", ...): No Such File or Directory

(com.valvesoftware.steam.ipctool[nnn]) Exited with Code: 1

(com.valvesoftware.steam.ipctool) Throttling Respawn: Will start in 10 seconds

Obviously, Steam is still sending some command, but it fails each time as the folder is not there. How can I find where this command is coming from, and how to delete whatever is causing it?

jam

Posted 2010-07-19T18:38:46.007

Reputation: 3

Answers

0

You can check through this list of directories (see "man launchd.plist"):

 ~/Library/LaunchAgents         Per-user agents provided by the user.
 /Library/LaunchAgents          Per-user agents provided by the administrator.
 /Library/LaunchDaemons         System-wide daemons provided by the administrator.
 /System/Library/LaunchAgents   Per-user agents provided by Mac OS X.
 /System/Library/LaunchDaemons  System-wide daemons provided by Mac OS X.

You might find some files there related to your steam application. I hope this points you in the right direction. I don't know off hand the correct/best way to fix the problem once you find the file(s).

Marnix A. van Ammers

Posted 2010-07-19T18:38:46.007

Reputation: 1 978

Yep, this is it! I actually found it myself just a second ago. It was a LaunchDaemon that appzapper failed to delete; deleting it solved the problem. I also cleaned out a few other obsolete ones that were kickin' around in there. Cheers! – jam – 2010-07-19T19:36:01.020

To unload/stop a launchd job run launchctl stop <label> or launchctl unload <path to plist> – Chealion – 2010-07-19T21:30:40.287